Discussion:
Build error on some platforms
(too old to reply)
Gunter Königsmann
2017-07-20 07:01:10 UTC
Permalink
Raw Message
Dear all,

Currently the Maxima build seems on some systems to run into an error:

/<<PKGBUILDDIR>>/share/draw//drawutils.texi:151: Prev field of node `Venn diagrams' not pointed to. /<<PKGBUILDDIR>>/share/draw//drawutils.texi:36: This node (Vector fields) has the bad Next. /<<PKGBUILDDIR>>/share/draw//drawutils.texi:36: Next field of node `Vector fields' not pointed to (perhaps incorrect sectioning?). /<<PKGBUILDDIR>>/share/draw//drawutils.texi:196: This node (Function and variable index) has the bad Prev. makeinfo: Removing output file `/<<PKGBUILDDIR>>/share/draw/drawutils.info' due to errors; use --force to preserve. make[3]: *** [drawutils.info] Error 1

The full build log can be found at:

https://launchpadlibrarian.net/329818561/buildlog_ubuntu-precise-i386.maxima_5.40.0-0~201707200453~ubuntu12.04.1_BUILDING.txt.gz

The good news is that with massive help from the Debian developers I have now managed to fix the Debian build issues:

The presence of a directory named "binary" made the Debian build system think that the packages had already been built and installed in debian/tmp

Kind regards,

Gunter.
--
Diese Nachricht wurde von meinem Android-GerÀt mit K-9 Mail gesendet.
Robert Dodier
2017-07-21 05:38:07 UTC
Permalink
Raw Message
Post by Gunter Königsmann
/<<PKGBUILDDIR>>/share/draw//drawutils.texi:151: Prev field of node `Venn diagrams' not pointed to.
I think I've fixed this in commit 2cd5991. Thanks for pointing it out.

I don't get that error when I process drawutils.texi with makeinfo --
maybe it's because I'm using a different version (makeinfo 5.2). Anyway
the @node stuff was indeed incorrect but I think I've fixed it.

best

Robert Dodier
Gunter Königsmann
2017-07-21 16:04:53 UTC
Permalink
Raw Message
Post by Robert Dodier
Post by Gunter Königsmann
/<<PKGBUILDDIR>>/share/draw//drawutils.texi:151: Prev field of node `Venn diagrams' not pointed to.
I think I've fixed this in commit 2cd5991. Thanks for pointing it out.
I don't get that error when I process drawutils.texi with makeinfo --
maybe it's because I'm using a different version (makeinfo 5.2). Anyway
You have. Thanks a lot!

That means we now have nightly builds for maxima for 5 Ubuntu versions,
2 lisps and 2 processors that all run through compiler and testbench
without errors which is something the maxima team can be proud of. For
details see
https://code.launchpad.net/~maxima-developers/+recipe/maxima-daily.
Ubuntu Artful currently fails due to
https://bugs.launchpad.net/ubuntu/+source/texlive-base/+bug/1699781, but
we cannot do anything about that bug in the ubuntu release.

As I have stated the failure to build maxima on arm computers using
clisp might be a clisp bug.
http://wolfgang.dautermann.at/maxima/nightlybuild/logfile-summary.txt
tells us that acl and ecl currently produce testbench failures, though.

Kind regards,

Gunter.

Loading...